1 (425) 274-4500
My Cart

Heartbleed Bug Update


Published on 4/10/2014

We recently learned about a serious vulnerability in OpenSSL Certificates, known as the Heartbleed Bug. This vulnerability has existed for more than two years, and compromises the security of passwords, credit cards, and other sensitive information.

Since this has widespread implications on the Internet, we wanted to inform you of this issue and assure you that eNom makes every effort to keep our systems patched to limit the impact of security vulnerabilities. Updates have been made to our systems to ensure that we remain unaffected by this vulnerability.

If you are running your own systems with OpenSSL versions 1.0.1 through 1.0.1f, your system is vulnerable and we suggest upgrading to a more recent version.

For more information, please visit http://heartbleed.com.